using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Test\d)_([A-Za-z0-9]+)(?:_([A-Za-z0-9]+))?";
string input = @"Test1_MYSTRING_val1
Test1_MYSTRING";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}