Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})
/
gm
Input 1
1
New
.aClass.foo.bar .qwerty { border-bottom: 1px solid color.get('primary'); padding: .5em; background-color: color.get('background'); .foo>.bar { background-image: url("paper.gif"); } .aCamelCaseClass { } #anIdThatShouldNotBeMatched { } .foo > .bar { background-image: url("paper.gif"); } .qwe+.rew>.qwe{ } .qwe:hover { } }