#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.*?)-"
Local $sString = "[program:hlds] : Название программы. Служит для управления." & @CRLF & _
"user - Пользователь от которого запускать сервер" & @CRLF & _
"environment - /steam путь к home директории пользователя от которого запускаем процесс. Все остальное оставляем как есть" & @CRLF & _
"process_name - имя процесса" & @CRLF & _
"directory - путь к директории сервера" & @CRLF & _
"command - команда запуска. Обратите внимания на hlds_linux вместо hlds_run" & @CRLF & _
"numprocs - количество процессов. В нашем случае 1" & @CRLF & _
"startretries - количество попыток автоподнятия при падении. При превышении сервер больше не поднимется" & @CRLF & _
"autostart - автозапуск при запуске ОС" & @CRLF & _
"autorestart - автоперезапуск при падении" & @CRLF & _
"stdout_logfile - путь к логфайлу" & @CRLF & _
"stdout_logfile_maxbytes - максимальный размер лог файла" & @CRLF & _
"stdout_logfile_backups - максимальное количество лог файлов" & @CRLF & _
"redirect_stderr - переадресация потока ошибок" & @CRLF & _
"stderr_logfile - путь к логу ошибок" & @CRLF & _
"stderr_logfile_maxbytes - максимальный размер файла ошибок" & @CRLF & _
"stderr_logfile_backups - максимальное количество файлов - ошибок" & @CRLF & _
"" & @CRLF & _
"## найти первое тире"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")