import Foundation
let pattern = #"(^.*?)-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
[program:hlds] : Название программы. Служит для управления.
user - Пользователь от которого запускать сервер
environment - /steam путь к home директории пользователя от которого запускаем процесс. Все остальное оставляем как есть
process_name - имя процесса
directory - путь к директории сервера
command - команда запуска. Обратите внимания на hlds_linux вместо hlds_run
numprocs - количество процессов. В нашем случае 1
startretries - количество попыток автоподнятия при падении. При превышении сервер больше не поднимется
autostart - автозапуск при запуске ОС
autorestart - автоперезапуск при падении
stdout_logfile - путь к логфайлу
stdout_logfile_maxbytes - максимальный размер лог файла
stdout_logfile_backups - максимальное количество лог файлов
redirect_stderr - переадресация потока ошибок
stderr_logfile - путь к логу ошибок
stderr_logfile_maxbytes - максимальный размер файла ошибок
stderr_logfile_backups - максимальное количество файлов - ошибок
## найти первое тире
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)