$re = '/(https?:\/\/[^\s]+)/';
$str = 'https://yadi.sk/d/bty6b765b5u5bu6';
$subst = "<a href=\"\1\">Я.Диск</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;