#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(?:[a-zA-Z0-9]{0,4}:?){1,8}\]|\[(?:[a-zA-Z0-9]{0,4}:?){1,4}(?:[0-9]{1,3}\.){3}[0-9]{1,3}\]"
Local $sString = "[::1]" & @CRLF & _
"[:a:1]" & @CRLF & _
"[:bh:lh:1]" & @CRLF & _
"[1:1:fEd1:1:abdc:1]" & @CRLF & _
"[::ffff:192.0.2.128]" & @CRLF & _
"[0000:0000:0000:0000:0000:0000:0000:0001]" & @CRLF & _
"[2001:0db8:0000:0000:0000:ff00:0042:8329]" & @CRLF & _
"[2001:db8:0:0:0:ff00:42:8329]" & @CRLF & _
"[2001:db8::ff00:42:8329]" & @CRLF & _
"[2001:0db8:0000:0000:0000:ff00:0042:8329]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")