use strict;
my $str = 'Shawn
/// <reference path="../../typings/include.d.ts"/>
Lovelidge
/// <reference path="../system/library.ts"/>';
my $regex = qr/(\/\/\/)\s+(<|>)(.*)(<|>)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";