package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){{{data(?:\|\d+)?}}}`)
var str = `{{{data}}}
{{{data|1}}}
{{{data|1|2|3|4|5}}}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}