import Foundation
let pattern = #"encoding=(\"\S+")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?xml version="1.0" encoding="ISO-8859-5" standalone="no"?>
<ProcessBudgetInformation releaseID="9.0" systemEnvironmentCode="Test" versionID="115.0">
<ApplicationArea>
<Sender>
<Logi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}