#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d+)(\s?)((?:ff|f)+\.?)(?=\s)"
Local $sString = "00f aaa + " & @CRLF & _
"00f. aaa +" & @CRLF & _
"00ff aaa +" & @CRLF & _
"00ff. aaa +" & @CRLF & _
"00 f aaa + " & @CRLF & _
"00 f. aaa aaa +" & @CRLF & _
"00 ff aaa +" & @CRLF & _
"00 ff. aaa +" & @CRLF & _
"+ aaa 00f aaa +" & @CRLF & _
"+ aaa 00f. aaa +" & @CRLF & _
"+ aaa 00ff aaa +" & @CRLF & _
"+ aaa 00ff. aaa +" & @CRLF & _
"+ aaa 00 f aaa + " & @CRLF & _
"+ aaa 00 f. aaa +" & @CRLF & _
"+ aaa 00 ff aaa +" & @CRLF & _
"+ aaa 00 ff. aaa +" & @CRLF & _
"+ aaa 00f" & @CRLF & _
"+ aaa 00f." & @CRLF & _
"+ aaa 00ff" & @CRLF & _
"+ aaa 00ff." & @CRLF & _
"+ aaa 00 f " & @CRLF & _
"+ aaa 00 f." & @CRLF & _
"+ aaa 00 ff" & @CRLF & _
"+ aaa 00 ff." & @CRLF & _
"" & @CRLF & _
"00 faaa -" & @CRLF & _
"00 f.aaa -" & @CRLF & _
"00 ffaaa -" & @CRLF & _
"00 ff.aaa -" & @CRLF & _
"00af aaa - " & @CRLF & _
"00af. aaa -" & @CRLF & _
"00aff aaa -" & @CRLF & _
"00aff. aaa -" & @CRLF & _
"- aaa 00 faaa -" & @CRLF & _
"- aaa 00 f.aaa -" & @CRLF & _
"- aaa 00 ffaaa -" & @CRLF & _
"- aaa 00 ff.aaa -" & @CRLF & _
"- aaa 00af aaa - " & @CRLF & _
"- aaa 00af. aaa -" & @CRLF & _
"- aaa 00aff aaa -" & @CRLF & _
"- aaa 00aff. aaa -" & @CRLF & _
"- aaa00f" & @CRLF & _
"- aaa00f." & @CRLF & _
"- aaa00ff" & @CRLF & _
"- aaa00ff." & @CRLF & _
"- aaa 00af " & @CRLF & _
"- aaa 00af." & @CRLF & _
"- aaa 00aff" & @CRLF & _
"- aaa 00aff." & @CRLF & _
"" & @CRLF & _
"00faaa -" & @CRLF & _
"00f.aaa -" & @CRLF & _
"00ffaaa -" & @CRLF & _
"00ff.aaa -" & @CRLF & _
"00af aaa - " & @CRLF & _
"00af. aaa -" & @CRLF & _
"00aff aaa -" & @CRLF & _
"00aff. aaa -" & @CRLF & _
"- aaa00 faaa -" & @CRLF & _
"- aaa00 f.aaa -" & @CRLF & _
"- aaa00 ffaaa -" & @CRLF & _
"- aaa00 ff.aaa -" & @CRLF & _
"- aaa00af aaa - " & @CRLF & _
"- aaa00af. aaa -" & @CRLF & _
"- aaa00aff aaa -" & @CRLF & _
"- aaa00aff. aaa -" & @CRLF & _
"- aaa00af " & @CRLF & _
"- aaa00af." & @CRLF & _
"- aaa00aff" & @CRLF & _
"- aaa00aff."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)