#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\s\S]*smsKod: (\d{8})[\s\S]*"
Local $sString = "smsKod: 24992129 dla " & @CRLF & _
"operacji: zmiana limitów " & @CRLF & _
"transakcyjnych 27.03.2015" & @CRLF & _
"11.17"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")