re = /(?<=[\][)]\s)(#(.*))$/m
str = '(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)
([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)
(\\||\\[|\\?) # match some stuff (escaped opening square bracket)
[A-Za-z # letters
0-9_-.] # stuff
(\\[) # works if escaped [ is in group
\\[ # but not if it\'s on its own...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end