// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$").unwrap();
let string = "132563_01_r2.jpg";
let substitution = "@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}