using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(start((?!start).)*?end)";
string input = @"start spam
start rubbish
start wait for it...
profit!
here end
start garbage
start second match
win. end";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}