$re = '/(start((?!start).)*?end)/s';
$str = 'start spam
start rubbish
start wait for it...
profit!
here end
start garbage
start second match
win. end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);