re = /(start((?!start).)*?end)/
str = 'start spam
start rubbish
start wait for it...
profit!
here end
start garbage
start second match
win. end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end