package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^http:\/\/myanimelist\.net\/animelist\/(.*[^\/])(?:\/|)$`)
var str = `http://myanimelist.net/animelist/YOURUSERNAME`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}