$re = '/(?<![\d.])(?:\d*\.\d+|\d+\.\d*)(?![\d.])/m';
$str = '1.0A
1.B
.1
.
1.0.0
1.0.1
20.20.20.30
12345.657.345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);