$re = '/(text1)[\s\S]*(text2)|\2[\s\S]*\1/';
$str = 'text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);