# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D*(\d+).*/$1/gm;t' <<< "P1, PROTECTED 1
P3, PROTECTED 3
P10, PROTECTED 10"