#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\D*(\d+).*"
Local $sString = "P1, PROTECTED 1" & @CRLF & _
"P3, PROTECTED 3" & @CRLF & _
"P10, PROTECTED 10"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)