use strict;
my $str = 'c://abcd /abcdef/0012wetr_1234567890.csv';
my $regex = qr/.*/([^_]+).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";