$re = '/.*/([^_]+).*/m';
$str = 'c://abcd /abcdef/0012wetr_1234567890.csv';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;