import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'([^@']*@\\d[^@']*)'";
final String string = "'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'\n"
+ "export MYVAR=\"/dir/'package@1.1.k':$MYVAR\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}