const regex = /'([^@']*@\d[^@']*)'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'([^@\']*@\\d[^@\']*)\'', 'gm')
const str = `'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'
export MYVAR="/dir/'package@1.1.k':\$MYVAR"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);