re = /'([^@']*@\d[^@']*)'/m
str = '\'package@1.1.k\' \'otherpackage@14\' \'anotherpackage@7.8\'
export MYVAR="/dir/\'package@1.1.k\':$MYVAR"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result