// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'([^@']*@\d[^@']*)'").unwrap();
let string = "'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'
export MYVAR=\"/dir/'package@1.1.k':$MYVAR\"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}