#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "( xmlns:?[^=]*=[""][^""]*[""])"
Local $sString = "<?xml version="1.0" encoding="utf-8"?>" & @CRLF & _
"<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">" & @CRLF & _
" <soap:Body>" & @CRLF & _
" <ConnectResponse xmlns="aa">" & @CRLF & _
" <ConnectResult xmlns="bb">" & @CRLF & _
" <RETURNS>" & @CRLF & _
" <STATUS>A92A7EBEE897499fA8B06D5FE94B8A30</STATUS>" & @CRLF & _
" <APIPAYLOAD>" & @CRLF & _
" <COMMAND>" & @CRLF & _
" <TRACKINGID mya="cc">e3d1618b4b7847628b10d4a432ec9151</TRACKINGID>" & @CRLF & _
" </COMMAND>" & @CRLF & _
" </APIPAYLOAD>" & @CRLF & _
" </RETURNS>" & @CRLF & _
" </ConnectResult>" & @CRLF & _
" </ConnectResponse>" & @CRLF & _
" </soap:Body>" & @CRLF & _
"</soap:Envelope>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")