package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([?&])\s*&`)
var str = `test1?&test2
test2&&test2
test3? &test2
test4? &test2
test5& &test2
test1& &test2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}