using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[\w_\-]+\b\/";
string substitution = @".../";
string input = @"p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}