package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\w_\-]+\b\/`)
var str = `p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file`
var substitution = ".../"
fmt.Println(re.ReplaceAllString(str, substitution))
}