use strict;
my $str = 'p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file';
my $regex = qr/\b[\w_\-]+\b\//p;
my $subst = '.../';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";