# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?: )*).+(?:\n\1((?: )+).*)(?:\n\1(?:(?: )+).*)*"
test_str = ("\n\n\n\n\n\n\n\n"
"i need help\n\n\n\n\n\n"
"for i in range(math.ceil(30/len(word)), 0, -1):\n"
" if len(tried) > 0:\n"
" print(\"so far you have tried \", \", \".join(tried))\n"
" print(\"lives\", i)\n"
" while \"_\" in show:\n"
" print(show)\n"
" letter = input(\"type your guess : \")\n"
" if letter in tried:\n"
" print(\"You already tried that letter!\")\n"
" continue\n"
" \n"
" tried.extend(letter)\n"
" if letter in word:\n"
" # loop\n"
" print(\"You got it right!\")\n"
" for l in range(0, len(word)):\n"
" if word[l] == letter:\n"
" show = show[:l] + letter + show[l+1:]\n"
" \n"
" else:\n"
" print(\"You guess incorrectly :(\")\n"
" break\n"
" if \"_\" not in show:\n"
" print(\"You won!\")\n"
" exit()\n"
"print(\"You lost :(\")\n\n\n\n\n\n\n\n"
"hi i want help on my skript\n\n\n\n"
"```\n"
"command /ownerrankgrant [<player>]:\n"
" permission: op\n"
" permission message: &cNOPE! NOT YET\n"
" trigger:\n"
" add arg-1 to {owner::*}\n"
" make console execute command \"/op %arg-1%\"\n\n\n"
" trigger:\n"
" add arg-1 to {owner::*}\n"
" make console execute command \"/op %arg-1%\"\n\n"
"on chat:\n"
" if {owner::*} contains the player:\n"
" set chat format to \"&6&l[&e&lOWNER&6&l] &e%player% &f>> &b%message%\"\n"
" else:\n"
" set chat format to \"&8[&7DEFAULT&8] &7%player% &f>> &7%message%\"\n\n"
"command /ownerrankremove [<player>]:\n"
" permission: op\n"
" permission message: &cNOPE! NOT YET!\n"
" trigger:\n"
" remove arg-1 from {owner::*}\n"
" make console execute command \"/deop %arg-1%\"\n"
"```")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.