re = /^((?: )*).+(?:\n\1((?: )+).*)(?:\n\1(?:(?: )+).*)*/m
str = '
i need help
for i in range(math.ceil(30/len(word)), 0, -1):
if len(tried) > 0:
print("so far you have tried ", ", ".join(tried))
print("lives", i)
while "_" in show:
print(show)
letter = input("type your guess : ")
if letter in tried:
print("You already tried that letter!")
continue
tried.extend(letter)
if letter in word:
# loop
print("You got it right!")
for l in range(0, len(word)):
if word[l] == letter:
show = show[:l] + letter + show[l+1:]
else:
print("You guess incorrectly :(")
break
if "_" not in show:
print("You won!")
exit()
print("You lost :(")
hi i want help on my skript
```
command /ownerrankgrant [<player>]:
permission: op
permission message: &cNOPE! NOT YET
trigger:
add arg-1 to {owner::*}
make console execute command "/op %arg-1%"
trigger:
add arg-1 to {owner::*}
make console execute command "/op %arg-1%"
on chat:
if {owner::*} contains the player:
set chat format to "&6&l[&e&lOWNER&6&l] &e%player% &f>> &b%message%"
else:
set chat format to "&8[&7DEFAULT&8] &7%player% &f>> &7%message%"
command /ownerrankremove [<player>]:
permission: op
permission message: &cNOPE! NOT YET!
trigger:
remove arg-1 from {owner::*}
make console execute command "/deop %arg-1%"
```'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end