package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(https?:\/\/[^\s]+?\.[^\s]+)$`)
var str = `http://example.com
https://example.com`
var substitution = "<a href="$1">auto link</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}