$re = '/\b(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[-A-Z0-9+&@#\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\/%=~_|$]|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|\'(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^\'\r\n]+\'/is';
$str = 'Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);