import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dashboard_|composition_";
final String string = "page_dashboard\n"
+ "dashboard_trainings\n"
+ "composition_trainings\n"
+ "ltr\n"
+ "fr\n"
+ "js\n"
+ "yjctmvqc\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}