#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "site[\s\S]{0,100}\/a>"
Local $sString = "<body>" & @CRLF & _
"<!-- Websites navigation menu -->" & @CRLF & _
"<ul class="navbar">" & @CRLF & _
"<li><a href="index.html">Home page</a>" & @CRLF & _
"<li><a href="musings.html">Musings</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"In the following code, what is the regex (within Sublime's search) for finding "site" (seen within "Websites") and /a> (seen within ) only when there are between 0 and 50 characters of any type in between those two strings? I'd like to be able to perform searches like this on a regular basis, just changing out the two keywords and a distance, thanks."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")