import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "site[\\s\\S]{0,100}\\/a>";
final String string = "<body>\n"
+ "<!-- Websites navigation menu -->\n"
+ "<ul class=\"navbar\">\n"
+ "<li><a href=\"index.html\">Home page</a>\n"
+ "<li><a href=\"musings.html\">Musings</a>\n\n\n"
+ "In the following code, what is the regex (within Sublime's search) for finding \"site\" (seen within \"Websites\") and /a> (seen within ) only when there are between 0 and 50 characters of any type in between those two strings? I'd like to be able to perform searches like this on a regular basis, just changing out the two keywords and a distance, thanks.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}