package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^{(([a-zA-Z0-9]+:[a-zA-Z0-9]+)(,[a-zA-Z0-9]+:[a-zA-Z0-9]+)*)?}$`)
var str = `{key1:value1,key2:value2}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}