$re = '/^.{7}$|(^\d{1,7}?$\.?\r?\n?)/m';
$str = '1
12
123
1234
12345
123456
1234567
123456!
123456\'
123456^
123456+
123456%
123456&
123456/
123456(
123456)
123456=
123456_
123456-
+123456
!autoit
autoit+
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);