using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{(?>[^}{]+|(?0))*}} ?";
string substitution = @"";
string input = @"Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}