const regex = /{{(?>[^}{]+|(?0))*}} ?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{(?>[^}{]+|(?0))*}} ?', 'g')
const str = `Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);