using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?://regex101\.com/r/([^\W_]{6})$";
string input = @"http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2
http://regex101.com/r/fW0_Z2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}