#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\/page\/)\d+"
Local $sString = "http://retail.domain.co.uk/view_orders/page/6/10?type=completed"
Local $sSubst = "$11"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)