using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/page\/)\d+";
string substitution = @"$11";
string input = @"http://retail.domain.co.uk/view_orders/page/6/10?type=completed";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}