$re = '/(\/page\/)\d+/';
$str = 'http://retail.domain.co.uk/view_orders/page/6/10?type=completed';
$subst = "$11";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;