import Foundation
let pattern = #"(\/page\/)\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://retail.domain.co.uk/view_orders/page/6/10?type=completed"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$11"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}