use strict;
my $str = 'Foo (.* ) bar blla (.* ) b*l?a$ && bla bla ';
my $regex = qr~\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])~ip;
my $subst = '\\\\\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";