#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[\p{N}\p{L}\-+\.]{1,500}\.[\p{N}\p{L}][\p{L}-]*[\p{N}\p{L}]+$"
Local $sString = "google.com" & @CRLF & _
"masełkowski.pl" & @CRLF & _
"maselkowski.pl" & @CRLF & _
"m.maselkowski.pl" & @CRLF & _
"www.masełkowski.pl.com" & @CRLF & _
"xn--masekowski-d0b.pl" & @CRLF & _
"中国互联网络信息中心.中国" & @CRLF & _
"masełkowski.pl." & @CRLF & _
"masełk..owski.pl" & @CRLF & _
"中国互联网络信息中心.xn--masekowski-d0b" & @CRLF & _
"api.aaaaaaaaaaaaaaaaaa34.23ab34bcde.343434343434343434.a1b2c3d4.urab.org" & @CRLF & _
"xxx" & @CRLF & _
"ayx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")